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                                               CORE COURSE  VI 

                                      OFFICE PROGRAMMING  
 

Objective : To understand the theory as well as practical knowledge of MS-
Word, MS- PowerPoint and MS-Excel. 

 
Internal Assessment: Theory – 15 Marks; Practical – 10 
Marks University Examinations : Theory- 45 Marks ; 
Practical - 30 Marks. Examination Duration : Theory 
2 Hours ; Practical 2 Hours 

 

(Theory & Practical) (Theory 45 Marks) 

UNIT – I 
Introduction to Computers – Classification – Generation – Memory Units – 
Auxiliary Storage Devices – Areas of Computers – Input and Output devices. 
MS-Word : Working with Menus – File, Edit, View, Insert, Format, Tools and 
Tables 
- Find and  Replace -  Header and Footer – Spelling and Grammar. 

 
UNIT – II 

Introduction to Spreadsheets –  Entering  data’s  in  Worksheet  –  Editing  and 
Formating worksheets - Formula bars – Types of Charts and Diagrams – 
Functions in Excel – Auto controlling – Protect sheet. 

 
UNIT – III 

MS- Powerpoint – Adding and Formatting text - Insert pictures – Slide design - 
Slide Layout  –  Background  –  Insert  Pictures,  Clip  Art  and  Diagrams  –   Movie   
and Sounds – Custom Animation. 

(PRACTICAL – 30 Marks) 
 

UNIT – IV 
Preparation of Word Document - Paragraph Alignment – Page setup – 
Preparation of Business    letter – Preparation of Bio-data – Mail merge – Page 
columns – Creation of Tables. 

 
UNIT – V 

MS- Excel – Mark Statement Preparation – Electricity Bill Preparation – Pay bill 
preparation – Creating Charts. 
MS-Powerpoint – Slide Preparation – Background colour settings – Insert 
pictures – Slide Number – Slide Design – Custom Animation – Draw Table. 



                

 

 

 

                                UNIT-I 

Why this chapter 
 

Computers are an integral part of our lives. Wherever we are—sitting in our homes, working 
in the office, driving on roads, sitting in a movie hall, staying in a hotel, etc.—our lives are 
directly or indirectly affected by the computers. In this era of information, we are dependent 
on the storage, flow and processing of data and information, which can only be possible with 
the help of computers. The purpose of this chapter is to introduce you to the “computer”. 

 
1.1 INTRODUCTION 

 

Nowadays, computers are an integral part of our lives. They are used for the reservation of 
tickets for airplanes and railways, payment of telephone and electricity bills, deposit and 
withdrawal of money from banks, processing of business data, forecasting of weather 
conditions, diagnosis of diseases, searching for information on the Internet, etc. Computers 
are also used extensively in schools, universities, organizations, music industry, movie 
industry, scientific research, law firms, fashion industry, etc. 

 
The term computer is derived from the word compute. The word compute means to 
calculate. A computer is an electronic machine that accepts data from the user, processes the 
data by performing calculations and operations on it, and generates the desired output 
results. Computer performs both simple and complex operations, with speed and accuracy. 

 
This chapter discusses the history and evolution of computer, the concept of input-process-
output and the characteristics of computer. This chapter also discusses the classification of 
digital computers based on their size and type, and the application of computer in different 
domain areas. 

 
1.2 DIGITAL AND ANALOG COMPUTERS 

 
A digital computer uses distinct values to represent the data internally. All information are 
represented using the digits Os and 1s. The computers that we use at our homes and offices 
are digital computers. 

 
Analog computer is another kind of a computer that represents data as variable across a 
continuous range of values. The earliest computers were analog computers. Analog 
computers are used for measuring of parameters that vary continuously in real time, such 
as temperature, pressure and voltage. Analog computers may be more flexible but generally 



less precise than digital computers. Slide rule is an example of an analog computer. 
 

This book deals only with the digital computer and uses the term computer for them. 
 
 

 
1.3 CHARACTERISTICS OF COMPUTER 

 
Speed, accuracy, diligence, storage capability and versatility are some of the key 
characteristics of a computer. A brief overview of these characteristics are— 

 
 Speed The computer can process data very fast, at the rate of millions of instructions per 

second. Some calculations that would have taken hours and days to complete otherwise, 

can be completed in a few seconds using the computer. For example, calculation and 

generation of salary slips of thousands of employees of an organization, weather 

forecasting that requires analysis of a large amount of data related to temperature, 

pressure and humidity of various places, etc. 

 Accuracy Computer provides a high degree of accuracy. For example, the computer can 

accurately give the result of division of any two numbers up to 10 decimal places. 

 Diligence When used for a longer period of time, the computer does not get tired or 

fatigued. It can perform long and complex calculations with the same speed and accuracy 

from the start till the end. 

 Storage Capability Large volumes of data and information can be stored in the computer 

and also retrieved whenever required. A limited amount of data can be stored, 

temporarily, in the primary memory. Secondary storage devices like floppy disk and 

compact disk can store a large amount of data permanently. 

 

 Versatility Computer is versatile in nature. It can perform different types of tasks with the 

same ease. At one moment you can use the computer to prepare a letter document and in 

the next moment you may play music or print a document. 

 
Computers have several limitations too. Computer can only perform tasks that it has been 
programmed to do. Computer cannot do any work without instructions from the user. It 
executes instructions as specified by the user and does not take its own decisions. 

 
1.4 HISTORY OF COMPUTER 

 
Until the development of the first generation computers based on vacuum tubes, there had 
been several developments in the computing technology related to the mechanical 
computing devices. The key developments that took place till the first computer was 
developed are as follows— 

 
 Calculating Machines ABACUS was the first mechanical calculating device for 

counting of large numbers. The word ABACUS means calculating board. It consists of 

bars in horizontal positions on which sets of beads are inserted. The horizontal bars have 

10 beads each, representing units, tens, hundreds, etc. An abacus is shown in Figure 1.1 
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Figure 1.1 Abacus 
 

 Napier’s Bones was a mechanical device built for the purpose of multiplication in 1617 

ad. by an English mathematician John Napier. 

 Slide Rule was developed by an English mathematician Edmund Gunter in the 16th 

century. Using the slide rule, one could perform operations like addition, subtraction, 

multiplication and division. It was used extensively till late 1970s. Figure 1.2 shows a 

slide rule. 

 

 
 

Figure 1.2 Slide rule 
 

 Pascal’s Adding and Subtraction Machine was developed by Blaise Pascal. It could add 

and subtract. The machine consisted of wheels, gears and cylinders. 

 Leibniz’s Multiplication and Dividing Machine was a mechanical device that could both 

multiply and divide. The German philosopher and mathematician Gottfried Leibniz built 

it around 1673. 

 Punch Card System was developed by Jacquard to control the power loom in 1801. He 

invented the punched card reader that could recognize the presence of hole in the punched 

card as binary one and the absence of the hole as binary zero. The Os and 1s are the basis 

of the modern digital computer. A punched card is shown in Figure 1.3. 
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Figure 1.3 Punched card 
 

 Babbage’s Analytical Engine An English man Charles Babbage built a mechanical 

machine to do complex mathematical calculations, in the year 1823. The machine was 

called as difference engine. Later, Charles Babbage and Lady Ada Lovelace developed a 

general-purpose calculating machine, the analytical engine. Charles Babbage is also 

called the father of computer. 

 Hollerith’s Punched Card Tabulating Machine was invented by Herman Hollerith. The 

machine could read the information from a punched card and process it electronically. 

 
The developments discussed above and several others not discussed here, resulted in the 
development of the first computer in the 1940s. 
 
 

1.5 GENERATIONS OF COMPUTER 

The computer has evolved from a large—sized simple calculating machine to a smaller but 
much more powerful machine. The evolution of computer to the current state is defined in 
terms of the generations of computer. Each generation of computer is designed based on a 
new technological development, resulting in better, cheaper and smaller computers that are 
more powerful, faster and efficient than their predecessors. Currently, there are five 
generations of computer. In the following subsections, we will discuss the generations of 
computer in terms of— 

 
1. the technology used by them (hardware and software), 

2. computing characteristics (speed, i.e., number of instructions executed per second), 

3. physical appearance, and 

4. their applications. 

 
1.5.1 First Generation (1940 to 1956): Using Vacuum Tubes 

 
 Hardware Technology The first generation of computers used vacuum tubes (Figure 1.4) 

for circuitry and magnetic drums for memory. The input to the computer was through 

punched cards and paper tapes. The output was displayed as printouts. 
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Figure 1.4 Vacuum tube 
 

 Software Technology The instructions were written in machine language. Machine 

language uses 0s and 1s for coding of the instructions. The first generation computers 

could solve one problem at a time. 

 Computing Characteristics The computation time was in milliseconds. 

 Physical Appearance These computers were enormous in size and required a large room 

for installation. 

 Application They were used for scientific applications as they were the fastest computing 

device of their time. 

 Examples UNIVersal Automatic Computer (UNIVAC), Electronic Numerical Integrator 

And Calculator (ENIAC), and Electronic Discrete Variable Automatic Computer 

(EDVAC). 

 

The first generation computers used a large number of vacuum tubes and thus generated a 
lot of heat. They consumed a great deal of electricity and were expensive to operate. The 
machines were prone to frequent malfunctioning and required constant maintenance. Since 
first generation computers used machine language, they were difficult to program. 

 
1.5.2 Second Generation (1956 to 1963): Using Transistors 

 
 Hardware Technology Transistors (Figure 1.5) replaced the vacuum tubes of the first 

generation of computers. Transistors allowed computers to become smaller, faster, 

cheaper, energy efficient and reliable. The second generation computers used magnetic 

core technology for primary memory. They used magnetic tapes and magnetic disks for 

secondary storage. The input was still through punched cards and the output using 

printouts. They used the concept of a stored program, where instructions were stored in 

the memory of computer. 
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Figure 1.5 Transistors 
 

 Software Technology The instructions were written using the assembly language. 

Assembly language uses mnemonics like ADD for addition and SUB for subtraction for 

coding of the instructions. It is easier to write instructions in assembly language, as 

compared to writing instructions in machine language. High-level programming 

languages, such as early versions of COBOL and FORTRAN were also developed during 

this period. 

 Computing Characteristics The computation time was in microseconds. 

 Physical Appearance Transistors are smaller in size compared to vacuum tubes, thus, the 

size of the computer was also reduced. 

 Application The cost of commercial production of these computers was very high, 

though less than the first generation computers. The transistors had to be assembled 

manually in second generation computers. 

 

 Examples PDP-8, IBM 1401 and CDC 1604. 

 
Second generation computers generated a lot of heat but much less than the first generation 
computers. They required less maintenance than the first generation computers. 

 
1.5.3 Third Generation (1964 to 1971): Using Integrated Circuits 

 
 Hardware Technology The third generation computers used the Integrated Circuit (IC) 

chips. Figure 1.6 shows IC chips. In an IC chip, multiple transistors are placed on a 

silicon chip. Silicon is a type of semiconductor. The use of IC chip increased the speed 

and the efficiency of computer, manifold. The keyboard and monitor were used to 

interact with the third generation computer, instead of the punched card and printouts. 
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Figure 1.6 IC chips 
 

 Software Technology The keyboard and the monitor were interfaced through the 

operating system. Operating system allowed different applications to run at the same 

time. High-level languages were used extensively for programming, instead of machine 

language and assembly language. 

 Computing Characteristics The computation time was in nanoseconds. 

 Physical Appearance The size of these computers was quite small compared to the 
second generation computers. 

 Application Computers became accessible to mass audience. Computers were produced 

commercially, and were smaller and cheaper than their predecessors. 

 Examples IBM 370, PDP 11. 

 
The third generation computers used less power and generated less heat than the second 
generation computers. The cost of the computer reduced significantly, as individual 
components of the computer were not required to be assembled manually. The maintenance 
cost of the computers was also less compared to their predecessors. 

 
1.5.4 Fourth Generation (1971 to present): Using Microprocessors 

 
 Hardware Technology They use the Large Scale Integration (LSI) and the Very Large 

Scale Integration (VLSI) technology. Thousands of transistors are integrated on a small 

silicon chip using LSI technology. VLSI allows hundreds of thousands of components to 

be integrated in a small chip. This era is marked by the development of microprocessor. 

Microprocessor is a chip containing millions of transistors and components, and, 

designed using LSI and VLSI technology. A microprocessor chip is shown in Figure 
1.7. This generation of computers gave rise to Personal Computer (PC). 
Semiconductor memory replaced the earlier magnetic core memory, resulting in fast 
random access to memory. Secondary storage device like magnetic disks became 
smaller in physical size and larger in capacity. The linking of computers is another 
key development of this era. The computers were linked to form networks that led 
to the emergence of the Internet. 
This generation also saw the development of pointing devices like mouse, and 
handheld devices. 
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Figure 1.7 Microprocessors 
 

 Software Technology Several new operating systems like the MS-DOS and MS- Windows 

developed during this time. This generation of computers supported Graphical User 

Interface (GUI). GUI is a user-friendly interface that allows user to interact with the 

computer via menus and icons. High-level programming languages are used for the writing 

of programs. 

 Computing Characteristics The computation time is in picoseconds. 

 Physical Appearance They are smaller than the computers of the previous generation. 

Some can even fit into the palm of the hand. 

 Application They became widely available for commercial purposes. Personalcomputers 

became available to the home user. 

 Examples The Intel 4004 chip was the first microprocessor. The components of the 

computer like Central Processing Unit (CPU) and memory were located on a single chip. 

In 1981, IBM introduced the first computer for home use. In 1984, Apple introduced the 

Macintosh. 

 
The microprocessor has resulted in the fourth generation computers being smaller and 
cheaper than their predecessors. The fourth generation computers are also portable and 
more reliable. They generate much lesser heat and require less maintenance compared to 
their predecessors. GUI and pointing devices facilitate easy use and learning on the 
computer. Networking has resulted in resource sharing and communication among different 
computers. 

 
1.5.5 Fifth Generation (Present and Next): Using Artificial Intelligence 

 
The goal of fifth generation computing is to develop computers that are capable of learning 
and self-organization. The fifth generation computers use Super Large Scale Integrated 
(SLSI) chips that are able to store millions of components on a single chip. These computers 
have large memory requirements. 

 
This generation of computers uses parallel processing that allows several instructions to be 
executed in parallel, instead of serial execution. Parallel processing results in faster 
processing speed. The Intel dualcore microprocessor uses parallel processing. 

 
The fifth generation computers are based on Artificial Intelligence (AI). They try to simulate 
the human way of thinking and reasoning. Artificial Intelligence includes areas like Expert 
System (ES), Natural Language Processing (NLP), speech recognition, voice recognition, 
robotics, etc. R.NITHYA,ASSISTANT 

PROFESSOR, ANNAI WOMEN'S 
COLLEGE,KARUR 



 
1.6 CLASSIFICATION OF COMPUTER 

 
The digital computers that are available nowadays vary in their sizes and types. The 
computers are broadly classified into four categories (Figure 1.8) based on their size and 
type—(1) Microcomputers, (2) Minicomputers, (3) Mainframe computers, and (4) 
Supercomputer. 

 

Figure 1.8 Classification of computers based on size and type 
 

1.6.1 Microcomputers 
 

Microcomputers are small, low-cost and single-user digital computer. They consist of CPU, 
input unit, output unit, storage unit and the software. Although microcomputers are stand-
alone machines, they can be connected together to create a network of computers that can 
serve more than one user. IBM PC based on Pentium microprocessor and Apple Macintosh 
are some 

examples of microcomputers. Microcomputers include desktop computers, notebook 
computers or laptop, tablet computer, handheld computer, smart phones and netbook, as 
shown in Figure 1.9.  
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Figure 1.9 Microcomputers 
 

 Desktop Computer or Personal Computer (PC) is the most common type of 

microcomputer. It is a stand-alone machine that can be placed on the desk. Externally, it 

consists of three units—keyboard, monitor, and a system unit containing the CPU, 

memory, hard disk drive, etc. It is not very expensive and is suited to the needs of a single 

user at home, small business units, and organizations. Apple, Microsoft, HP, Dell and 

Lenovo are some of the PC manufacturers. 

 Notebook Computers or Laptop resemble a notebook. They are portable and have all the 

features of a desktop computer. The advantage of the laptop is that it is small in size (can 

be put inside a briefcase), can be carried anywhere, has a battery backup and has all the 

functionality of the desktop. Laptops can be placed on the lap while working (hence the 

name). Laptops are costlier than the desktop machines. 

 Netbook These are smaller notebooks optimized for low weight and low cost, and are 

designed for accessing web-based applications. Starting with the earliest netbook in late 

2007, they have gained significant popularity now. Netbooks deliver the performance 

needed to enjoy popular activities like streaming videos or music, emailing, Web surfing 

or instant messaging. The word netbook was created as a blend of Internet and notebook. 
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 Tablet Computer has features of the notebook computer but it can accept input from a 

stylus or a pen instead of the keyboard or mouse. It is a portable computer. Tablet 

computer are the new kind of PCs. 

 Handheld Computer or Personal Digital Assistant (PDA) is a small computer that can be 

held on the top of the palm. It is small in size. Instead of the keyboard, PDA uses a pen or 

a stylus for input. PDAs do not have a disk drive. They have a limited memory and are less 

powerful. PDAs can be connected to the Internet via a wireless connection. Casio and 

Apple are some of the manufacturers of PDA. Over the last few years, PDAs have merged 

into mobile phones to create smart phones. 

 Smart Phones are cellular phones that function both as a phone and as a small PC. They 

may use a stylus or a pen, or may have a small keyboard. They can be connected to the 

Internet wirelessly. They are used to access the electronic-mail, download music, play 

games, etc. Blackberry, Apple, HTC, Nokia and LG are some of the manufacturers of 

smart phones. 

 
1.6.2 Minicomputers 

 
Minicomputers (Figure 1.10) are digital computers, generally used in multi-user systems. 
They have high processing speed and high storage capacity than the microcomputers. 
Minicomputers can support 4–200 users simultaneously. The users can access the 
minicomputer through their PCs or terminal. They are used for real-time applications in 
industries, research centers, etc. PDP 11, IBM (8000 series) are some of the widely used 
minicomputers. 

 

Figure 1.10 Minicomputer 
 

1.6.3 Mainframe Computers 
 

Mainframe computers (Figure 1.11) are multi-user, multi-programming and high 
performance computers. They operate at a very high speed, have very large storage capacity 
and can handle the workload of many users. Mainframe computers are large and powerful 
systems generally used in centralized databases. The user accesses the mainframe computer 
via a terminal that may be a dumb terminal, an intelligent terminal or a PC. A dumb terminal 
cannot store data or do processing of its own. It has the input and output device only. An 
intelligent terminal has the input and output device, can do processing, but, cannot store data 
of its own. The dumb and the intelligent terminal use the processing power and the storage 
facility of the mainframe computer. Mainframe computers are used in organizations like 
banks or companies, where many people 
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require frequent access to the same data. Some examples of mainframes are CDC 6600 and 
IBM ES000 series. 

 

Figure 1.11 Mainframe computer 
 

1.6.4 Supercomputers 
 

Supercomputers (Figure 1.12) are the fastest and the most expensive machines. They have 
high processing speed compared to other computers. The speed of a supercomputer is 
generally measured in FLOPS (FLoating point Operations Per Second). Some of the faster 
supercomputers can perform trillions of calculations per second. Supercomputers are built 
by interconnecting thousands of processors that can work in parallel. 

 
Supercomputers are used for highly calculation-intensive tasks, such as, weather 
forecasting, climate research (global warming), molecular research, biological research, 
nuclear research and aircraft design. They are also used in major universities, military 
agencies and scientific research laboratories. Some examples of supercomputers are IBM 
Roadrunner, IBM Blue gene and Intel ASCI red. PARAM is a series of supercomputer 
assembled in India by C-DAC (Center for Development of Advanced Computing), in Pune. 
PARAM Padma is the latest machine in this series. The peak computing power of PARAM 
Padma is 1 Tera FLOP (TFLOP). 
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Figure 1.12 Supercomputer 
 

1.7 THE COMPUTER SYSTEM 

 
Computer is an electronic device that accepts data as input, processes the input data by 
performing mathematical and logical operations on it, and gives the desired output. The 
computer system consists of four parts•(1) Hardware, (2) Software, (3) Data, and (4) Users. 
The parts of computer system are shown in Figure 1.13. 

 

Hardware consists of the mechanical parts that make up the computer as a machine. The 
hardware consists of physical devices of the computer. The devices are required for input, 
output, storage and processing of the data. Keyboard, monitor, hard disk drive, floppy disk 
drive, printer, processor and motherboard are some of the hardware devices. 
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Figure 1.13 Parts of computer system 
 

Software is a set of instructions that tells the computer about the tasks to be performed and 
how these tasks are to be performed. Program is a set of instructions, written in a language 
understood by the computer, to perform a specific task. A set of programs and documents 
are collectively called software. The hardware of the computer system cannot perform any 
task on its own. The hardware needs to be instructed about the task to be performed. 
Software instructs the computer about the task to be performed. The hardware carries out 
these tasks. Different software can be loaded on the same hardware to perform different 
kinds of tasks. 

 
Data are isolated values or raw facts, which by themselves have no much significance. For 
example, the data like 29, January, and 1994 just represent values. The data is provided as 
input to the computer, which is processed to generate some meaningful information. For 
example, 29, January and 1994 are processed by the computer to give the date of birth of a 
person. 

 
Users are people who write computer programs or interact with the computer. They are also 
known as skinware, liveware, humanware or peopleware. Programmers, data entry operators, 
system analyst and computer hardware engineers fall into this category. 

 
1.7.1 The Input-Process-Output Concept 

 
A computer is an electronic device that (1) accepts data, (2) processes data, (3) generates 
output, and (4) stores data. The concept of generating output information from the input 4 
data is also referred to as input-process-output concept. 
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The input-process-output concept of the computer is explained as follows— 
 

 Input The computer accepts input data from the user via an input device like keyboard. 

The input data can be characters, word, text, sound, images, document, etc. 

 Process The computer processes the input data. For this, it performs some actions on the 

data by using the instructions or program given by the user of the data. The action could 

be an arithmetic or logic calculation, editing, modifying a document, etc. During 

processing, the data, instructions and the output are stored temporarily in the computer’s 

main memory. 

 Output The output is the result generated after the processing of data. The output may be 

in the form of text, sound, image, document, etc. The computer may display the output on 

a monitor, send output to the printer for printing, play the output, etc. 

 Storage The input data, instructions and output are stored permanently in the secondary 

storage devices like disk or tape. The stored data can be retrieved later, whenever needed. 

 
1.7.2 Components of Computer Hardware 

 
The computer system hardware comprises of three main components — 

 
1. Input/Output (I/O) Unit, 

2. Central Processing Unit (CPU), and 

3. Memory Unit. 

 
The I/O unit consists of the input unit and the output unit. CPU performs calculations and 
processing on the input data, to generate the output. The memory unit is used to store the 
data, the instructions and the output information. Figure 1.14 illustrates the typical 
interaction among the different components of the computer. 

 

Figure 1.14 The computer system interaction 
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 Input/Output Unit The user interacts with the computer via the I/O unit. The Input unit 

accepts data from the user and the Output unit provides the processed data i.e. the 

information to the user. The Input unit converts the data that it accepts from the user, into 

a form that is understandable by the computer. Similarly, the Output unit provides the 

output in a form that is understandable by the user. The input is provided to the computer 

using input devices like keyboard, trackball and mouse. Some of the commonly used 

output devices are monitor and printer. 

 Central Processing Unit CPU controls, coordinates and supervises the operations ofthe 

computer. It is responsible for processing of the input data. CPU consists of Arithmetic 

Logic Unit (ALU) and Control Unit (CU). 

o ALU performs all the arithmetic and logic operations on the input data. 
o CU controls the overall operations of the computer i.e. it checks the sequence of 

execution of instructions, and, controls and coordinates the overall functioning of 

the units of computer. 

 
Additionally, CPU also has a set of registers for temporary storage of data, instructions, 
addresses and intermediate results of calculation. 

 
 Memory Unit Memory unit stores the data, instructions, intermediate results and output, 

temporarily, during the processing of data. This memory is also called the main memory 

or primary memory of the computer. The input data that is to be processed is brought into 

the main memory before processing. The instructions required for processing of data and 

any intermediate results are also stored in the main memory. The output is stored in 

memory before being transferred to the output device. CPU can work with the information 

stored in the main memory. Another kind of storage unit is also referred toas the secondary 

memory of the computer. The data, the programs and the output are stored permanently in 

the storage unit of the computer. Magnetic disks, optical disks and magnetic tapes are 

examples of secondary memory. 

 
1.8 APPLICATION OF COMPUTERS 

 
Computers have proliferated into various areas of our lives. For a user, computer is a tool 
that provides the desired information, whenever needed. You may use computer to get 
information about the reservation of tickets (railways, airplanes and cinema halls), books in 
a library, medical history of a person, a place in a map, or the dictionary meaning of a word. 
The information may be presented to you in the form of text, images, video clips, etc. 

 
Figure 1.15 shows some of the applications of computer. Some of the application areas of the 
computer are listed below— 

 
 Education Computers are extensively used, as a tool and as an aid, for imparting 

education. Educators use computers to prepare notes and presentations of their lectures. 

Computers are used to develop computer-based training packages, to provide distance 

education using the e-learning software, and to conduct online examinations. Researchers 

use computers to get easy access to conference and journal details and to get global access 

to the research material. 
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 Entertainment Computers have had a major impact on the entertainment industry. The 

user can download and view movies, play games, chat, book tickets for cinema halls, use 

multimedia for making movies, incorporate visual and sound effects using computers, 

etc. The users can also listen to music, download and share music, create music using 

computers, etc. 

 Sports A computer can be used to watch a game, view the scores, improve the game, play 

games (like chess, etc.) and create games. They are also used for the purposes of training 

players. 

 Advertising Computer is a powerful advertising media. Advertisement can be displayed 

on different websites, electronic-mails can be sent and reviews of a product by different 

customers can be posted. Computers are also used to create an advertisement using the 

visual and the sound effects. For the advertisers, computer is a medium via which the 

advertisements can be viewed globally. Web advertising has become a significant factor 

in the marketing plans of almost all companies. In fact, the business model of Google is 

mainly dependent on web advertising for generating revenues. 

 

 

Figure 1.15 Applications of computer 
 

 Medicine Medical researchers and practitioners use computers to access information 

about the advances in medical research or to take opinion of doctors globally. The medical 

history of patients is stored in the computers. Computers are also an integralpart of various 

kinds of sophisticated medical equipments like ultrasound machine, CAT scan machine, 

MRI scan machine, etc. Computers also provide assistance to the medical surgeons during 

critical surgery operations like laparoscopic operations, etc. 

 Science and Engineering Scientists and engineers use computers for performing 

complex scientific calculations, for designing and making drawings (CAD/CAM 

applications) and also for simulating and testing the designs. Computers are used for 

storing the complex data, performing complex calculations and for visualizing 3– 
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dimensional objects. Complex scientific applications like the launch of the rockets, space 
exploration, etc., are not possible without the computers. 

 Government The government uses computers to manage its own operations and also for e-

governance. The websites of the different government departments provide information to the users. 

Computers are used for the filing of income tax return, paying taxes, online submission of water and 

electricity bills, for the access of land record details, etc. The police department uses computers to 

search for criminals using fingerprint matching, etc. 

 Home Computers have now become an integral part of home equipment. At home, people use 

computers to play games, to maintain the home accounts, for communicating with friends and 

relatives via Internet, for paying bills, for education and learning, etc. Microprocessors are embedded 

in house hold utilities like, washing machines, TVs, food processors, home theatres, security devices, 

etc. 

 
The list of applications of computers is so long that it is not possible to discuss all of them here. In 
addition to the applications of the computers discussed above, computers have also proliferated into 
areas like banks, investments, stock trading, accounting, ticket reservation, military operations, 
meteorological predictions, social networking, business organizations, police department, video 
conferencing, telepresence, book publishing, web newspapers, and information sharing. 
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 File Menu: The File tab will bring you into the Backstage View. The 
Backstage View is where you manage your files and the data about them 
– creating, opening, printing, saving, inspecting for hidden metadata or 
personal information, and setting options. 

 Ribbon: An area across the top of the screen that makes almost all 

the capabilities of Word available in a single area. 

 Tabs: An area on the Ribbon that contains buttons that are 

organized in groups. The default tabs are Home, Insert, Design, 

Layout, References, Mailings, Review, View and EndNote X5. 

 Title Bar: A horizontal bar at the top of an active document. This 

bar displays the name of the document and application. At the 

right end of the Title Bar is the Minimize, Maximize and Close 

buttons. 

 Groups: A group of buttons on a tab that are exposed and easily accessible. 

 Dialog Box Launcher: A button in the corner of a group that 

launches a dialog box containing all the options within that group. 

 Status Bar: A horizontal bar at the bottom of an active 

window that gives details about the document. 

 View Toolbar: A toolbar that enables, adjusts, and displays 

different views of a document. 

 Zoom: Magnifies or reduces the contents in the document window. 

 Quick Access Toolbar: A customizable toolbar at the top of an 

active document. By default the Quick Access Toolbar displays the 

Save, Undo, and Repeat buttons and is used for easy access to 

frequently used commands. To customize this toolbar, click on the 

dropdown arrow and select the commands you want to add. 

 Tell Me: This is a text field where you can enter words and phrases 

about what you want to do next and quickly get to features you want 

to use or actions you want to perform. You can also use Tell Me to 

find help about what you're looking for, or to use Smart Lookup to 

research or define the term you entered. 

 

Contextual Tabs are designed to appear on the Ribbon when certain 
objects or commands are selected. These tabs provide easy access to 
options specific to the selected object or command. For example, the 
commands for editing a picture will not be available until the picture is 
selected, at which time the Picture Tools tab will appear. 

 



 

To Create a New Word Document: 

1) Click the File tab 
2) Click New 

3) Click Blank Document 
 
 

 

Navigating in a Document 

The following table lists ways to navigate in a document using your 
keyboard to move the insertion point in an active document: 



 

To Display Different Views: 

1) Click the View tab 
2) Click on the desired view 

 

View Options: 
 Read Mode: Displays as much of the content of the document as will fit in 

the screen. 

 Print Layout View: Shows a document as it appears on a printed page. 

 Web Layout View: Shows a document as it appears in a web browser. 

 Outline View: Shows the structure of a document, which consist of 

heading and body text. 

 Draft View: Displays the content of a document with a basic layout. 

~OR~ 
 

3) Click a View button on the View Toolbar in the lower right corner of the Status 
Bar 

 

 



Editing and Proofing Documents 

Selecting Text 

 Select a word: Click and drag or double-click on the word 
 Select a sentence: Click and drag or click in the sentence while 

holding down the CTRL key 

 Select a paragraph: Click and drag or triple-click in the paragraph 
or double-click in the selection area to the left of the paragraph 

 Select a block of text: Click and drag or click to the left of the 
first word, hold down the SHIFT key, and then immediately click to 
the right of the last word 

 Select a line: Click and drag or click in the selection to the left of the line 
 Select an entire document: Triple-click in the selection area 

or hit the CTRL + A keys 
 Undo an action: On the Quick Access Toolbar click the Undo key 

 

 

 
 

Deleting Text 

When deleting text in your document you can either use the Delete key or 
the Backspace key. The Delete key deletes text to the right of your cursor 
while the Backspace key deletes text to the left of your cursor. 

Cut, Copy and Paste 

Often times you will need to move text from one location in a document to 
another, or to a different application. In this case you will perform a Cut 

and Paste. To reproduce a specific part of a document and place it 
elsewhere, you will perform a Copy and Paste. 

 

To Cut Text: 

1) Select the text you want to move 

2) Click on the Cut icon located on the Home tab in the Clipboard 

group 
 

 

To Copy Text: 

1) Select the text you want to copy 

2) Click on the Copy icon located on the Home tab in the Clipboard 

group 



 
To Paste Text: 

1) Click in the area of the document where you want to paste your text 

2) Click on the Paste icon   located on the Home tab in the Clipboard group 

 
Formatting a Document 

To Make Font Changes: 

1) Select the desired text that you want to format 
2) Choose commands from the Font group on the Home tab 
3) For additional formatting options, click on the Dialog Box 

Launcher in the lower-right corner of the group to launch the Font 

dialog box 
 

You can also use the MiniToolbar. The Mini Toolbar is activated when 
you select text to be formatted. This toolbar is miniature and semi-
transparent to help you work with fonts, font styles, font sizing, alignment, 
text color, indent levels, and bullet features. 

 

Live Preview 

Using Live Preview temporarily applies formatting on selected text 
or objects whenever a formatting command is hovered. This allows 
you to quickly preview how the formatting options will look before 
they are made. 

 
1) Select the desired text that you want to format 
2) On the Home tab, in the Font group, do any of the following: 



a. Click the arrow next to the Font box and move the pointer 

over the fonts that you want to preview. 

b. Click the arrow next to the Font Size box and move the 

pointer over the font sizes that you want to preview. 

c. Click the arrow next to the Text Highlight Color button 

and move the pointer over the highlight or fill colors that 

you want to preview. 

d. Click the arrow next to the Font Color button and move 

the pointer over the font colors that you want to preview. 

When you finish previewing the formatting choices, do one of the following: 
 To apply the previewed formatting, click the selected font name, size, or color 

in the list. 

 To cancel live previewing without applying any changes, press ESC. 

 
Formatting a Paragraph 

A paragraph is a select group of text that can have its own formatting 
characteristics, such as alignment, spacing and styles. 

 
1) Select the desired paragraph(s) that you want to format 
2) Choose commands from the Paragraph group on the Home tab 
3) For additional formatting options, click on the Dialog Box 

Launcher in the lower-right corner of the group to launch the 
Paragraph dialog box 

 

You can also use the MiniToolbar. 

Previewing and Printing a Document 

1) Click the File tab 
2) Click Print 

 

This view includes print preview, print commands, as well as the print settings: 



 

 
 

Saving and Closing a New Document 

 
To Save a New Document 

1) On the Quick Access Toolbar, click the Save button 

 

~OR~ 
 

2) Click the File tab 
3) Click Save As 

4) Select the location, the Save As dialog box will appear 
 

5) In the File Name field, type the name of the document 
6) Click Save 

 
To Close a Document 

1) Click the File tab, and then click Close 

2) If a Microsoft Office Word dialog box appears displaying a “Do you 

want to save…?” message: 



 
Click Save to save, Don’t Save to discard changes, or Cancel to close the 
dialog box. 

 

 
 
 
 
 
 
 
 
 

                                              *********** 
 
 
 
 

UNIT-II 

MS-EXCEL 
Entering Text and Numbers 

1.1 The Microsoft Excel Window 

This Section will introduce you to the Excel window. To begin this Section, start 
Microsoft Excel 2007 as follows: 

 
 

1. Click on Microsoft Start Button 
2. Point the mouse on All Programs 
3. Click on Microsoft Office 
4. Click on Microsoft Excel 2007 



The Microsoft Excel window appears and your screen looks similar to the one shown 
here. 

 

1.2 The Microsoft Office Button 

In the upper-left corner of the Excel 2007 window is the Microsoft Office button. When 
you click the button, a menu appears. You can use the menu to create a new file, open an 
existing file, save a file, print and perform many other tasks. 

1.3 The Quick Access Toolbar 

Next to the Microsoft Office button is the Quick Access toolbar. The Quick Access toolbar 
gives you quick access to commands you frequently use. 

1.4 The Title Bar 

Next to the Quick Access toolbar is the Title bar. On the Title bar, Microsoft Excel displays 
the name of the workbook you are currently using. At the top of the Excel window, you 
should see "Book 1 - Microsoft Excel" or a similar name. 

1.5 The Ribbon 

In Microsoft Excel 2007, you use the Ribbon to issue commands. The Ribbon is located 
near the top of the Excel window, below the Quick Access toolbar. 

1.6 Worksheets 



 

Microsoft Excel consists of worksheets. Each worksheet contains columns and rows. The 
columns are lettered A to Z and then continuing with AA, AB, AC and so on; the rows are 
numbered 1 to 1,048,576. 

The combination of a column coordinate and a row coordinate make up a cell address. 
For example, the cell located in the upper-left corner of the worksheet is cell A1, 
meaning column A, row 1. Cell E10 is located under column E on row 10. You enter your 
data into the cells on the worksheet. 

1.7 The Formula Bar 
 

 

If the Formula bar is turned on, the cell address of the cell you are in displays in the Name 
box which is located on the left side of the Formula bar. Cell entries display on the right 
side of the Formula bar. 



1.8 The Status Bar 

The Status bar appears at the very bottom of the Excel window and provides such 
information as the sum, average, minimum, and maximum value of selected numbers. 

1.9 Move Around a Worksheet 

By using the arrow keys, you can move around your worksheet. You can use the down 
arrow key to move downward one cell at a time. You can use the up arrow key to 
move upward one cell at a time. You can use the Tab key to move across the page to the 
right, one cell at a time. You can hold down the Shift key and then press the Tab key to 
move to the left, one cell at a time. You can use the right and left arrow keys to move right 
or left one cell at a time. The Page Up and Page Down keys move up and down one page 
at a time. If you hold down the Ctrl key and then press the Home key, you move to the 
beginning of the worksheet. 

1.10 EXERCISE 1 

Move around the Worksheet using the Down and Up Arrow Keys, the Right and Left 
Arrow Keys, the Tab Key, the Page Up and Page Down Keys and the (Ctrl) Home Key. 

1.11 Go To Cells Quickly 

The following are shortcuts for moving quickly from one cell in a worksheet to a cell in a 
different part of the worksheet. 

1.12 EXERCISE 

2 Go to -- F5 

1. Press F5. The Go To dialog box opens. 

2. Type J3 in the Reference field. 
3. Press Enter. Excel moves to cell J3. 

Go to -- Ctrl+G 

1. Hold down the Ctrl key while you press "g" (Ctrl+g). The Go To dialog box 



opens. 

2. Type C4 in the Reference field. 
3. Press Enter. Excel moves to cell C4. 

Go To -- The Name Box 

You can also use the Name box to go to a specific cell. Just type the cell you want to go to 
in the Name box and then press Enter. 

1. Type B10 in the Name box. 
2. Press Enter. Excel moves to cell B10. 

 

1.13 Select Cells 

If you wish to perform a function on a group of cells, you must first select those cells by 
highlighting them. The exercises that follow teach you how to select. 

1.14 EXERCISE 

3 Select Cells – F8 

To select cells A1 to E7: 

1. Go to cell A1. 
2. Press the F8 key. This anchors the cursor. 

3. Note that "Extend Selection" appears on the Status bar in the lower-left 



corner of the window. You are in the Extend mode. 
4. Click in cell E7. Excel highlights cells A1 to E7. 
5. Press Esc and click anywhere on the worksheet to clear the highlighting. 

Alternative Method: Select Cells by Dragging 

1. Go to cell A1. 
2. Press the left mouse button. 
3. While holding down the left mouse button, use the mouse to move from cell 

A1 to C5. 

4. Release the left mouse button. 
5. Hold down the Ctrl key until step 9. 
6. Using the mouse, place the cursor in cell D7. 
7. Press the left mouse button. 
8. While holding down the left mouse button, move to cell F10. Release the left 

mouse button. 
9. Release the Ctrl key. Cells A1 to C5 and cells D7 to F10 are selected. 
10.Press Esc and click anywhere on the worksheet to remove the highlighting. 

1.15 Enter Data 
In this section, you will learn how to enter data into your worksheet. First, place the 
cursor in the cell in which you want to start entering data. Type some data, and then 
press Enter. If you need to delete, press the Backspace key to delete one character at a 
time. 



1.16 EXERCI

SE 4 Enter 

Data 

 

1. Place the cursor in cell A1. 
2. Type John Jordan. Do not press Enter at this time. 

1.17 Edit a Cell – F2 

After you enter data into a cell, you can edit the data by pressing F2 while you are in 
the cell you wish to edit. 

1.18 EXERCISE 5 

Change "John" to "Jones." 

1. Move to cell A1. 
2. Press F2. 
3. Use the Arrow and Backspace keys to change John to Jones 
4. Press Enter. 

Alternate Method: Editing a Cell by Using the Formula Bar 

You can also edit the cell by using the Formula bar. You change "Jones" to "Joker" in 
the following exercise. 

1. Move the cursor to cell A1. 
2. Click in the formula or entries area of the Formula bar, and change Jones 

to Joker. 

3. Press Enter. 
Alternate Method: Edit a Cell by Double-Clicking in the Cell 



You can change "Joker" to "Johnson" as follows: 

1. Move to cell A1. 
2. Double-click in cell A1. 
3. Use the Arrow and Backspace keys to change Joker to Johnson. 
4. Press Enter. 

Change a Cell Entry 

Typing in a cell replaces the old cell entry with the new information you type. 

1. Move the cursor to cell A1. 
2. Type Cathy. 
3. Press Enter. The name "Cathy" replaces "Johnson Jordan" 

1.19 Wrap Text 

When you type text that is too long to fit in the cell, the text overlaps the next cell. If 
you do not want it to overlap the next cell, you can wrap the text. 

1.20 EXERCISE 6 

1. Move to cell A2. 
2. Type Text too long to fit. 



3. Press Enter. 

4. Return to cell A2. 
5. Choose the Home tab. 

6. Click the Wrap Text button . Excel wraps the text in the cell. 

1.21 Delete a Cell Entry 

To delete an entry in a cell or a group of cells, you place the cursor in the cell or 
select the group of cells and press Delete. 

1.22 EXERCIS

E 7 Delete a 

Cell Entry 

1. Select cells A1 to A2. 
2. Press the Delete key. 

1.23 Save a File 

This is the end of Section 1. To save your file: 

1. Click the Office button. A menu appears. 
2. Click Save. The Save As dialog box appears. 
3. Go to the directory in which you want to save your file. 
4. Type Section1 in the File Name field. 
5. Click Save. Excel saves your file. 

1.24 Close Excel 

Close Microsoft Excel. 

1. Click the Office button. A menu appears. 
2. Click Close. Excel closes. 

Section 2: Entering Excel Formulas and Formatting Data 

Section 1 familiarized you with the Excel 2007 window, taught you how to move 
around the window, and how to enter data. A major strength of Excel is that you can 



perform mathematical calculations and format your data. In this Section, you will 
learn how to perform basic mathematical calculations and how to format text and 
numerical data. To start this Section, open Excel. 

2.1 Perform Mathematical Calculations 

In Microsoft Excel, you can enter numbers and mathematical formulas into cells. 
Whether you enter a number or a formula, you can reference the cell when you 
perform mathematical calculations such as addition, subtraction, multiplication, or 
division. When entering a mathematical formula, precede the formula with an equal 
(=) sign. Use the following to indicate the type of calculation you wish to perform: 

+ Addition 
– Subtraction 
* Multiplication 
/ Division 
^ Exponential 

In the following exercises, you practice some of the methods you can use to 
perform mathematical calculations. 

2.2 EXERCISE 1 

2.2.1 Addition, Subtraction, Multiplication and Division of Numbers 

1. Type: Add, Subtract, Multiply, and Divide in cells A1, B1, C1, and D1 
respectively 

2. Type: 12, 25, 11 and 75 in cells A2, B2, C2 and D2 respectively 
3. Type: 8, 13, 6 and 5 in cells A3, B3, C3 and D3 respectively 
4. Type: = A2 + A3 in cell A5 and press Enter 
5. Type: = B2 + B3 in cell A5 and press Enter 

6. Type: = C2 + C3 in cell A5 and press Enter 
7. Type: = D2 + D3 in cell A5 and press Enter 

When creating formulas, you can reference cells and include numbers. All of the 
following formulas are valid: 

(a) =A2/B2; (b) =A2+12-B3;      (c) =A2*B2+12;       (d) =24+53/B2 

2.2.2 Perform Advanced Mathematical Calculations 

When you perform mathematical calculations in Excel, be careful of precedence. 
Calculations are performed from left to right, with multiplication and division 



performed before addition and subtraction. 

2.3 EXERCISE 2 

Advanced 

Calculations 

1. Move to cell A7. 

2. Type =3+3+12/2*4. 
3. Press Enter. 

Note: Microsoft Excel divides 12 by 2, multiplies the answer by 4, adds 3, and then 
adds another 3. The answer, 30, displays in cell A7. 

To change the order of calculation, use parentheses. Microsoft Excel calculates the 
information in parentheses first. 

1. Double-click in cell A7. 
2. Edit the cell to read =(3+3+12)/2*4. 
3. Press Enter. 

Note: Microsoft Excel adds 3 plus 3 plus 12, divides the answer by 2, and then 
multiplies the result by 4. The answer, 36, displays in cell A7. 

2.4 AutoSum 

You can use the AutoSum button  on the Home tab to automatically add a column 

or row of numbers. When you press the AutoSum button , Excel selects the 
numbers it thinks you want to add. If you then click the check mark on the Formula 
bar or press the Enter key, Excel adds the numbers. If Excel's guess as to which 
numbers you want to add is wrong, you can select the cells you want. 

2.5 EXERCI

SE 3 AutoSum 



The following illustrates AutoSum: 

1. Go to cell F1. 
2. Type 3. 
3. Press Enter. Excel moves down one cell. 
4. Type 3. 
5. Press Enter. Excel moves down one cell. 
6. Type 3. 

7. Press Enter. Excel moves down one cell to cell F4. 
8. Choose the Home tab. 

9. Click the AutoSum button    in the Editing group. Excel selects cells F1 
through F3 and enters a formula in cell F4. 

10. Press Enter. Excel adds cells F1 through F3 and displays the result in cell F4. 

 

Note that you can click on the arrow next to AutoSum to access other automatic 
calculations like average, minimum and maximum values, count numbers, etc. 

2.6 Align Cell Entries 
When you type text into a cell, by default your entry aligns with the left side of the cell. 



When you type numbers into a cell, by default your entry aligns with the right side of 
the cell. You can change the cell alignment. You can center, left-align, or right-align any 
cell entry. Look at cells A1 to D1. Note that they are aligned with the left side of the 
cell. 

2.7 EXERCISE 4 

To center cells A1 to D1: 

1. Select cells A1 to D1. 
2. Choose the Home tab. 

3. Click the Center button  in the Alignment group. Excel centers each 
cell's content. 

Note that left and right alignment can be carried out in a similar manner. 

2.8 Copy, Cut and Paste 

You can copy or cut data from one area of a worksheet to another. 

1. Select cells D9 to D12 
2. Choose the Home tab. 

3. Click the Cut button. 



4. Move to cell G1. 

5. Click the Paste button . Excel moves the contents of cells D9 to D12 
to cells G1 to G4. 

2.9 Insert and Delete Columns and Rows 

You can insert and delete columns and rows. When you delete a column, you delete 
everything in the column from the top of the worksheet to the bottom of the 
worksheet. When you delete a row, you delete the entire row from left to right. 
Inserting a column or row inserts a completely new column or row. 

2.10 EXERCISE 5 

Insert and Delete Columns and Rows 

To delete columns F and G: 

1. Click the column F indicator and drag to column G. 
2. Click the down arrow next to Delete in the Cells group. A menu appears. 
3. Click Delete Sheet Columns. Excel deletes the columns you selected. 
4. Click anywhere on the worksheet to remove your selection. 



To delete rows 7 through 12: 

1. Click the row 7 indicator and drag to row 12. 
2. Click the down arrow next to Delete in the Cells group. A menu appears. 
3. Click Delete Sheet Rows. Excel deletes the rows you selected. 

4. Click anywhere on the worksheet to remove your 

selection. To insert a column: 

1. Click on A to select column A. 
2. Click the down arrow next to Insert in the Cells group. A menu appears. 
3. Click Insert Sheet Columns. Excel inserts a new column. 

4. Click anywhere on the worksheet to remove your 

selection. To insert rows: 

1. Click on 1 and then drag down to 2 to select rows 1 and 2. 
2. Click the down arrow next to Insert in the Cells group. A menu appears. 

3. Click Insert Sheet Rows. Excel inserts two new rows. 
4. Click anywhere on the worksheet to remove your selection. 

2.11 Work with Long Text 
Whenever you type text that is too long to fit into a cell, Microsoft Excel attempts to 
display all the text. It left-aligns the text regardless of the alignment you have assigned 
to it, and it borrows space from the blank cells to the right. However, a long text entry 
will never write over cells that already contain entries—instead, the cells that contain 
entries cut off the long text. The following exercise illustrates this. 

2.12 EXERCISE 

6 Work with 

Long Text 

 

1. Move to cell A6. 



2. Type Now is the time for all good men to go to the aid of their 
army. 

3. Press Enter. Everything that does not fit into cell A6 spills over into the 
adjacent cell. 

4. Move to cell B6. 
5. Type Test. 
6. Press Enter. Excel cuts off the entry in cell A6. 

7. Move to cell A6. 
8. Look at the Formula bar. The text is still in the cell. 

2.13 Change A Column's Width 

You can increase column widths. Increasing the column width enables you to see 
the long text. 

2.14 EXERCISE 7 

Change Column 

Width 

 

1. Make sure you are in any cell under column A. 
2. Choose the Home tab. 
3. Click the down arrow next to Format in the Cells group. 
4. Click Column Width. The Column Width dialog box appears. 
5. Type 55 in the Column Width field. 
6. Click OK. Column A is set to a width of 55. You should now be able to see 

all of the text. 
Change a Column Width by Dragging 



You can also change the column width with the cursor. 

1. Place the mouse pointer on the line between the B and C column headings. 

The mouse pointer should look like the one displayed here , with two 
arrows. 

2. Move your mouse to the right while holding down the left mouse button. 

The width indicator appears on the screen. 
3. Release the left mouse button when the width indicator shows 

approximately 
20. Excel increases the column width to 20. 

Change a Column Width by AutoFit Column Width 

1. Select the column or column you want to change the column width. 
2. Choose the Home tab. 
3. Click the down arrow next to Format in the Cells group. 
4. Click on AutoFit Column Width. You should now be able to see all of the 

text. 

2.15 Format Numbers 

You can format the numbers you enter into Microsoft Excel. For example, you can add 
commas to separate thousands, specify the number of decimal places, place a dollar 
sign in front of a number, or display a number as a percent. 

2.16 EXERCISE 8 

1. Move to cell 
B8. 2. Type 
1234567. 

3. Click the check mark [ √ ] on the Formula bar. 

4. Choose the Home tab. 
5. Click the down arrow next to the Number Format box. A menu appears. 
6. Click Number. Excel adds two decimal places to the number you typed. 



7.  Click the 
Comma Style button . Excel separates thousands with a comma. 

8. Click the Accounting Number Format button . Excel adds a dollar sign 
to your number. 

9. Click twice on the Increase Decimal button to change the number 
format to four decimal places. 

10. Click the Decrease Decimal button , if you wish to decrease the 
number of decimal places. 

Change a decimal to a percent. 

1. Move to cell B9. 
2. Type 0.35 (note the decimal point). 
3. Click the check mark [ √ ] on the formula bar. 

4. Choose the Home tab. 

5. Click the Percent Style button . Excel turns the decimal to a percent. 

This is the end of Section 2. You can save and close your file. See Section 1 
(Subsections 1.23 and 1.24) to learn how to save and close a file. 
Section 3: Creating Excel Functions, Filling Cells, and Printing 

By using functions, you can quickly and easily make many useful calculations, such 
as finding an average, the highest number, the lowest number, and a count of the 



number of items in a list. Microsoft Excel has many functions that you can use. 

3.1 Using Reference Operators 

To use functions, you need to understand reference operators. Reference operators 
refer to a cell or a group of cells. There are two types of reference operators: range and 
union. 

A range reference refers to all the cells between and including the reference. A range 
reference consists of two cell addresses separated by a colon. The reference A1:A3 
includes cells A1, A2, and A3. The reference A1:C3 includes cells A1, A2, A3, B1, B2, 
B3, C1, C2, and C3. 

A union reference includes two or more references. A union reference consists of two 
or more numbers, range references, or cell addresses separated by a comma. The 
reference A7,B8:B10,C9,10 refers to cells A7, B8 to B10, C9 and the number 10. 

3.2 Understanding Functions 

Functions are prewritten formulas. Functions differ from regular formulas in that you 
supply the value but not the operators, such as +, -, *, or /. For example, you can use 
the SUM function to add. When using a function, remember the following: 

1. Use an equal sign to begin a formula. 
2. Specify the function name. 
3. Enclose arguments within parentheses. Arguments are values on which you 

want to perform the calculation. For example, arguments specify the 
numbers or cells you want to add. 

4. Use a comma to separate 

arguments. Here is an example of a 

function: 

=SUM(2,13,A1,B2:C7) 

In this function, known as the SUM function: 

1. The equal sign begins the function. 
2. SUM is the name of the function. 
3. 2, 13, A1, and B2:C7 are the arguments. Parentheses enclose the 

arguments. 
4. Commas separate the arguments. 

After you type the first letter of a function name, the AutoComplete list appears. You 
can double-click on an item in the AutoComplete list to complete your entry quickly. 
Excel will complete the function name and enter the first parenthesis. 

3.1 Calculate an Average 



You can use the AVERAGE function to calculate the average of a series of numbers. 

1. Move to cell A6. 
2. Type Average. Press the right arrow key to move to cell B6. 
3. Type =AVERAGE(B1:B3). 
4. Press Enter. The average of cells B1 to B3, which is 21, appears. 

3.2 Find the Lowest Number 

You can use the MIN function to find the lowest number in a series of numbers. 

1. Move to cell A7. 
2. Type Min. Press the right arrow key to move to cell B7. 
3. Type =MIN(B1:B3). 
4. Press Enter. The lowest number in the series, which is 12, appears. 

3.3 Find the Highest Number 

You can use the MAX function to find the highest number in a series of numbers. 
 
 
 
 
 
 
 
 
 
 
 

. 

1. Move to cell A8. 



2. Type Max. Press the right arrow key to move to cell B8. 
3. Type =MAX(B1:B3). 
4. Press Enter. The highest number in the series, which is 27, appears. 

3.4 Fill Cells Automatically 

You can use Microsoft Excel to fill cells automatically with a series. For example, you 
can have Excel automatically fill your worksheet with days of the week, months of 
the year, years, or other types of series. 

3.5 EXERCISE 2 

(a) Fill Cells Automatically 

The following demonstrates filling the days of the week: 

1. Click the Sheet2 tab. Excel moves to Sheet2. 
2. Move to cell A1. 
3. Type Sun. 
4. Move to cell B1. 
5. Type Sunday. 
6. Select cells A1 to B1. 
7. Choose the Home tab. 

8. Click the Bold button . Excel bolds cells A1 to B1. 
9. Find the small black square in the lower-right corner of the selected area. 

The small black square is called the fill handle. 
10. Grab the fill handle and drag with your mouse to fill cells A1 to B14. Note 

how the days of the week fill the cells in a series. Also, note that the Auto Fill 
Options button appears. 



 

(b) Fill Numbers 

You can also fill numbers. 

1. Type a 1 in cell D1. 
2. Type a 2 in cell D2. 
3. Select cells D1:D2 
4. Grab the fill handle and drag with your mouse to highlight cells D1 to D14. 
5. The cells fill as a series, starting with 1, 

2, 3. Here is another interesting fill feature. 

1. Go to cell E1. 
2. Type Section 1. 
3. Grab the fill handle and drag with your mouse to highlight cells E1 to E14. 

The cells fill in as a series: Section 1, Section 2, Section 3, and so on. 

3.6 Set Print Options 

There are many print options. You set print options on the Page Layout tab. Among 
other things, you can set your margins, set your page orientation, and select your 
paper size. 

Margins define the amount of white space that appears on the top, bottom, left, 
and right edges of your document. The Margin option on the Page Layout tab provides 
several standard margin sizes from which you can choose. 

Paper comes in a variety of sizes. Most business correspondence uses 8 ½ by 11 paper, 
which is the default page size in Excel. If you are not using 8 ½ by 11 paper, you can 
use the Size option on the Page Layout tab to change the Size setting. 

Set the Page Layout (Margins) 



 

1. Choose the Page Layout tab. 
2. Click Margins in the Page Setup group. A menu appears. 
3. Click Wide. Excel sets your margins to the Wide settings. 

Set the Page Orientation 
 

1. Choose the Page Layout tab. 
2. Click Orientation in the Page Setup group. A menu appears. 
3. Click Landscape. Excel sets your page orientation to landscape. 

Set the Paper Size 

1. Choose the Page Layout tab. 
2. Click Size in the Page Setup group. A menu appears. 
3. Click the paper size you are using. Excel sets your page size. 

3.7 Print 

The simplest way to print is to click the Office button, highlight Print on the menu 
that appears, and then click Quick Print in the Preview and Print the Document pane. 
Dotted lines appear on your screen, and your document prints. The dotted lines 



indicate the right, left, top, and bottom edges of your printed pages. To print from 
Microsoft Excel, you can proceed as follows: 

1. Click on Microsoft Office Button  
2. Highlight or point the mouse on Print. 
3. Click on Print. 
4. In the Name box, under Printer option, choose an appropriate printer. 
5. Under the Print Range option, choose appropriate range of pages to 

be printed. 
6. Under Copies option, choose appropriate number of copies of each 

page to be printed. 

7. Click on OK when ready. 

3.8 EXERCI

SE 4 Print 

Preview 

 

1. Click the Office button. A menu appears. 
2. Highlight Print. The Preview and Print The Document pane appears. 
3. Click Print Preview. The Print Preview window appears, with your 

document in the center. 
Creating Charts 

In Microsoft Excel, you can represent numbers in a chart. On the Insert tab, you can 
choose from a variety of chart types, including column, line, pie, bar, area, and scatter. 
The basic procedure for creating a chart is the same no matter what type of chart you 
choose. As you change your data, your chart will automatically update. 



You select a chart type by choosing an option from the Insert tab's Chart group. 
After you choose a chart type, such as column, line, or bar, you choose a chart sub- 
type. For example, after you choose Column Chart, you can choose to have your 
chart represented as a two-dimensional chart, a three-dimensional chart, a cylinder 
chart, a cone chart, or a pyramid chart. There are further sub-types within each of 
these categories. As you roll your mouse pointer over each option, Excel supplies a 
brief description of each chart sub-type. 

 

4.1 Create a Chart 
 

To create the column chart shown above, start by creating the worksheet below 
exactly as shown. 

 

After you have created the worksheet, you are ready to create your chart. 

4.2 Create a 

Column Chart 

 
 
 
 
 
 
 
 
 



 
 

. 

1. Select cells A3 to D6. You must select all the cells containing the data 
you want in your chart. You should also include the data labels. 

2. Choose the Insert tab. 
3. Click the Column button in the Charts group. A list of column chart sub-

types types appears. 
4. Click the Clustered Column chart sub-type. Excel creates a Clustered 

Column chart and the Chart Tools context tabs appear. 

4.3 Apply a Chart Layout 

Context tabs are tabs that only appear when you need them. Called Chart Tools, there 
are three chart context tabs: Design, Layout, and Format. The tabs become available 
when you create a new chart or when you click on a chart. You can use these tabs to 
customize your chart. 

4.4 EXERCISE 2 

Apply a Chart 

Layout 

 

1. Click your chart. The Chart Tools become available. 

2. Choose the Design tab. 
3. Click the Quick Layout button in the Chart Layout group. A list of chart 

layouts appears. 

4. Click Layout 5. Excel applies the layout to your chart. 
4.1 Change the Style of a Chart 

A style is a set of formatting options. You can use a style to change the color and format 
of your chart. Excel 2007 has several predefined styles that you can use. They are 
numbered from left to right, starting with 1, which is located in the upper- left corner. 

4.2 EXERCISE 3 



Change the Style of a Chart 

1. Click your chart. The Chart Tools become available. 
2. Choose the Design tab. 

3. Click the More button   in the Chart Styles group. The chart styles appear. 

 
4. Click Style 42. Excel applies the style to your chart. 

4.5 Change the Size and Position of a Chart 

When you click a chart, handles appear on the right and left sides, the top and bottom, 
and the corners of the chart. You can drag the handles on the top and bottom of the 
chart to increase or decrease the height of the chart. You can drag the handles on 
the left and right sides to increase or decrease the width of the chart. You can 
drag the handles on the corners to increase or decrease the size of the chart 
proportionally. You can change the position of a chart by clicking on an unused area 
of the chart and dragging. 

 

4.6 EXERCISE 4 



Change the Size and Position of a Chart 

 
1. Use the handles to adjust the size of your chart. 
2. Click an unused portion of the chart and drag to position the chart beside 

the data. 

4.7 Move a Chart to a Chart Sheet 

By default, when you create a chart, Excel embeds the chart in the active worksheet. 
However, you can move a chart to another worksheet or to a chart sheet. A chart 
sheet is a sheet dedicated to a particular chart. By default Excel names each chart 
sheet sequentially, starting with Chart1. You can change the name. 



Move a Chart to a Chart Sheet 

1. Click your chart. The Chart Tools become available. 
2. Choose the Design tab. 
3. Click the Move Chart button in the Location group. The Move Chart 

dialog box appears. 

4. Click the New Sheet radio button. 

5. Type Toy Sales to name the chart sheet. Excel creates a chart sheet 
named Toy Sales and places your chart on it. 

4.8 Change the Chart Type 

Any change you can make to a chart that is embedded in a worksheet, you can also 
make to a chart sheet. For example, you can change the chart type from a column chart 
to a bar chart. 

 

                         ******** 
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                 MS-POWER POINT 

 

 
In this chapter, we will understand how to get started with 

PowerPoint 2010. We will understand how to start 
PowerPoint 2010 application in simple steps. To access 

PowerPoint 2010, you must have Microsoft Office 2010 
installed in your PC. Only Office 2010 Home and Student, 

Home and Business, Standard, Professional and Professional 
Plus packages have PowerPoint included in them. Other 

packages may have a viewer, but you cannot create 
presentations with them. 

Step 1: Click the Start button. 
 

Step 2: Click All Programs option from the menu. 



 

Step 3: Search for Microsoft Office from the sub menu and click it. 
 

Step 4: Search for Microsoft PowerPoint 2010 from the submenu and click it. 



PowerPoint 
2010 

 

 
This will launch the Microsoft PowerPoint 2010 application 
and you will see the following presentation window. 

 

The following screenshot shows the various areas in a 

standard PowerPoint file. It is important to familiarize 
yourself with these areas as it makes learning and using 

PowerPoint easier. 

 
PowerPoint 2010 ─ Exploring Windows 



 

File Tab 

This tab opens the Backstage view which basically allows 

you to manage the file and settings in PowerPoint. You can 
save presentations, open existing ones and create new 

presentations based on blank or predefined templates. The 
other file related operations can also be executed from this 

view. 

 



Ribbon 

The ribbon contains three components: 

 Tabs: They appear across the top of the Ribbon and contain groups 
of related commands. Home, Insert, Page Layout are examples of 

ribbon tabs. 

 Groups: They organize related commands; each group name 

appears below the group on the Ribbon. For example, a group of 

commands related to fonts or a group of commands related to 

alignment, etc. 

 Commands: Commands appear within each group as mentioned above. 

 
Title Bar 

This is the top section of the window. It shows the name of 

the file followed by the name of the program which in this 
case is Microsoft PowerPoint. 

 
Slide Area 

This is the area where the actual slide is created and edited. 
You can add, edit and delete text, images, shapes and 
multimedia in this section. 

Help 

The Help Icon can be used to get PowerPoint related help 

anytime you need. Clicking on the "?" opens the PowerPoint 
Help window where you have a list of common topics to 

browse from. You can also search for specific topics from the 
search bar at the top. 



 

 
Zoom Options 

The zoom control lets you zoom in for a closer look at your 
text. The zoom control consists of a slider that you can slide 
left or right to zoom in or out, you can click on the - and + 
buttons to increase or decrease the zoom factor. The 
maximum zoom supported by PowerPoint is 400% and the 
100% is indicated by the mark in the middle. 

Slide Views 

The group of four buttons located to the left of the Zoom 
control, near the bottom of the screen, lets you switch 
between PowerPoint views. 

 Normal Layout view: This displays page in normal view with the slide 

on the right and a list of thumbnails to the left. This view allows you 

to edit individual slides and also rearrange them. 



PowerPoint 
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 Slide Sorter view: This displays all the slides as a matrix. This view 

only allows you to rearrange the slides but not edit the contents of 

each slide. 

 Reading View: This view is like a slideshow with access to the 

Windows task bar in case you need to switch windows. However, 

like the slideshow you cannot edit anything in this view. 

 
Notes Section 

This sections allows you to add notes for the presentation. 

These notes will not be displayed on the screen during the 
presentation; these are just quick reference for the 

presenter. 

 
Quick Access Toolbar 

The Quick Access Toolbar is located just under the ribbon. 
This toolbar offers a convenient place to group the most 
commonly used commands in PowerPoint. You can 
customize this toolbar to suit your needs. 

 
Slide Tab 

This section is available only in the Normal view. It displays 
all the slides in sequence. You can add, delete and reorder 
slides from this section. 

In Office 2010, Microsoft replaced the traditional file menu 

with the new Backstage view. This view not only offers all 

the menu items under the file menu, but additional details 
which makes management of your files a lot easier. 

 
Accessing Backstage 

View

  

You can access the Backstage view simply by clicking on the 
File tab. You can exit this view by clicking on any tab 
(including the File tab again). You can also press the 'Esc' 
button on the keyboard. 

 

 
PowerPoint 2010 - Backstage View 



 

 First Pane: This is the commands pane which consists of all the 

commands you would typically find in the file menu of older versions. 

You also have the Options menu which lets you edit the options on 

the program like customizing the ribbon. Second Pane: This is the 

subcommands pane. This will list all the commands related to the 

main command you choose in the first pane. For example, if you 

select Print in the first pane, you get to choose the printer and 

adjust the print settings in the second pane. 

 
 Third Pane: This is the preview or file information page. Depending 

on the command and the subcommand you select, this pane will 

either display the properties of the file or give you a preview of the 

file. 

 

 
PowerPoint offers a host of tools that will aid you in creating a presentation. These tools are 
organized logically into various ribbons in PowerPoint. The table below describes the various 
commands you can access from the different menus. 
 
 
 
 



 
 

 
 
 

Step 2: The new slide is inserted. You can now change the 

layout of this slide to suit your design requirements. 
 



 

 

Step 3: To change the slide layout, right-click on the newly inserted slide 
and go to the 
Layout option where you can choose from the existing layout styles 
available to you. 



 
 
 
 
 

 You can follow the same steps to insert a new slide in 

between existing slides or at the end on the slide list. 
 

When we insert a new slide, it inherits the layout of its 

previous slide with one exception. If you are inserting a new 
slide after the first slide (Title slide), the subsequent slide 

will have the Title and Content layout. 
 

You will also notice that if you right-click in the first step 

without selecting any slide the menu options you get are 

different, although you can insert a new slide from this menu 

too. 



PowerPoint allows users to add text to the slide in a well-

defined manner to ensure the content is well distributed and 

easy to read. The procedure to add the text in a PowerPoint 

slide is always the same - just click in the text box and start 

typing. The text will follow the default formatting set for the 

text box, although this formatting can be changed later as 

required. What changes is the different kinds of content 

boxes that support text in a PowerPoint slide. 
 

Given below are some of the most common content blocks you will see in 
PowerPoint. 

 
Title Box 

This is typically found on slides with the title layout and in 

all the slides that have a title box in them. This box is 

indicated by "Click to add title". 

PowerPoint 2010 ─ Adding Text in Boxes 



 

Subtitle Box 

This is found only in slides with the Title layout. This is indicated by 
"Click to add subtitle". 

 
Content Box 

This is found in most of the slides that have a placeholder for 
adding content. This is indicated by "Click to add text". As 

you can see, this box allows you to add text as well as non-
text content. To add text to such a box, click anywhere on the 

box, except on one of the content icons in the center and start 
typing. 



 

Text Only Box 

This is not a default content box available in PowerPoint, but 

you can create it using Slide Master, if required. This is also 

indicated by "Click to add text". The only difference 

between the Text Only Box and the Content Box is that the 

former only supports text in the content area. 



 

This chapter will teach you how to add new text boxes in a slide. Most of 

the standard layouts come with the text box option. As mentioned in the 

previous chapter, text boxes will have "Click to add text" as the default 

text. Here are the steps to add new text boxes in slide. 

Step 1: Click on the Text Box icon in the Home ribbon under the Drawing section. 

 
 

 

Step 2: You will get the insert text box cursor that looks like an inverted 
cross. 

Step 3: Click to insert a text box. You can now start typing directly into 
the text box. 
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The size of the text box can be adjusted by selecting one of 

the edges marked by squares or corners marked by circles. 
 

There are times while building a slide deck, you may need to 

delete some slides. This can be done easily from PowerPoint. 

You can delete the slides from the Normal view as well as 

the Slide Sorter view. In each view, you can delete the slides 

in two ways. 

 
Deleting from Normal View 

Step 1: Go to the Normal view. 

 
PowerPoint 2010 ─ Deleting Existing Slide 



 

Step 2: Right-click on the slide to be deleted and select the Delete Slide option. 



 

Alternately, you can select the slide and press the Delete button on your 
key board. 

 
 

Deleting from Slide Sorter View 

Let us now understand how to deleted slides from the Slide Sorter View. 

Step 1: Go to the Slide Sorter view. 



 

Step 2: Right-click on the slide to be deleted and select the Delete Slide option. 



 

Rearranging slides is important when it comes to organizing 

the overall presentation flow. While it is vital that you get the 

right content in every slide, it is equally important that you 

are able to present them in a format that makes it easier for 

the audience to understand the content too; most times this 

will require rearranging the slides. 

You can rearrange slides from two views in PowerPoint - 

Normal View and Slide Sorter View. Given below are the 

steps to rearrange slides from different views. 

 
Normal 

View
  

Step 1: Select the slide to be moved 

Step 2: Left click on the slide and drag it to the position in 

the sequence where you want to place it. PowerPoint will 

indicate the insert position with a line in-between existing 

slides. 

PowerPoint 2010 ─ Rearranging Slides 



 

Step 3: When you get to the right position release the left 

click button to insert the slide. Alternately you can also cut the 

selected slide and paste it back in the sequence as shown 

below. 



 

 

Slide Sorter 
View
  

Let us now understand how the Slide Sorter View works. 

Step 1: Select the slide to be moved. 

Step 2: Left click on the slide and drag it to the position in 



the sequence where you want to place it. PowerPoint will 

indicate the insert position with a line in-between existing 
slides. 

 

Step 3: When you get to the right position, release the left click button to 
insert the slide 

Alternately you can also cut the selected slide and paste it 

back in the sequence as shown below. 
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